Installation

GraphQL::Pro is distributed as a Ruby gem. When you buy GraphQL::Pro, you’ll receive credentials, which you can register with bundler:

bundle config gems.graphql.pro #{YOUR_CREDENTIALS}

Then, you can add graphql-pro to your Gemfile, which a custom source:

source "https://gems.graphql.pro" do
  gem "graphql-pro"
end

Then, install the gem with Bundler:

bundle install

Then, check out some of GraphQL::Pro’s features!

Updates

To update GraphQL::Pro, use Bundler:

bundle update graphql-pro

Be sure to check the changelog between versions!

Dependencies

graphql-pro 1.0.0 requires graphql ~>1.4.

Verifying Integrity

You can verify the integrity of graphql-pro by getting its checksum and comparing it to the published checksums.

Include the graphql:pro:validate task in your Rakefile:

# Rakefile
require "graphql/rake_task/validate"

Then invoke it with a version:

$ bundle exec rake graphql:pro:validate[1.0.0]
Validating graphql-pro v1.0.0
  - Checking for graphql-pro credentials...
    ✓ found
  - Fetching the gem...
    ✓ fetched
  - Validating digest...
    ✓ validated from GitHub
    ✓ validated from graphql-ruby.org
✔ graphql-pro 1.0.0 validated successfully!

In case of a failure, please open an issue:

Validating graphql-pro v1.4.800
  - Checking for graphql-pro credentials...
    ✓ found
  - Fetching the gem...
    ✓ fetched
  - Validating digest...
    ✘ SHA mismatch:
      Downloaded:       c9cab2619aa6540605ce7922784fc84dbba3623383fdce6b17fde01d8da0aff49d666810c97f66310013c030e3ab7712094ee2d8f1ea9ce79aaf65c1684d992a
      GitHub:           404: Not Found
      graphql-ruby.org: 404: Not Found

      This download of graphql-pro is invalid, please open an issue:
      https://github.com/rmosolgo/graphql-ruby/issues/new?title=graphql-pro%20digest%20mismatch%20(1.4.800)